1 min read

Installing Coral USB Accelerator on Ubuntu 22.04 and Python 3.10 (11/2022)

Googles Coral USB Accelerator  isn't officially compiled for Python 3.10 or 3.11. Here is a shortcut without compiling the whole thing.

  1. Add Debian package repository to your system
echo "deb https://packages.cloud.google.com/apt coral-edgetpu-stable main" | sudo tee /etc/apt/sources.list.d/coral-edgetpu.list

curl https://packages.cloud.google.com/apt/doc/apt-key.gpg | sudo apt-key add -

sudo apt-get update

2. Install the Edge TPU runtime:

sudo apt-get install libedgetpu1-std

3. Install the PyCoral library:

sudo apt-get install python3-pycoral

Here is where you should get errors:

The following packages have unmet dependencies:
 python3-pycoral : Depends: python3-tflite-runtime (= 2.5.0.post1) but it is not going to be installed
                   Depends: python3 (< 3.10) but 3.10.6-1~22.04 is to be installed

Instead using apt-get install download 2 wheel files from this repository:

snippets/wheels/python3.10 at main · hjonnala/snippets
Contribute to hjonnala/snippets development by creating an account on GitHub.

and run:

pip install tflite_runtime-2.5.0.post1-cp310-cp310-linux_x86_64.whl
pip install pycoral-2.0.0-cp310-cp310-linux_x86_64.whl
Author image

Igor Rendulic

  • Salt Lake City
Explorer, developer, ... Using this website as the bookmarking service for the things that might become useful in the future.
You've successfully subscribed to Igor Technology
Great! Next, complete checkout for full access to Igor Technology
Welcome back! You've successfully signed in.
Success! Your account is fully activated, you now have access to all content.